chevy base mgtd

Home Forums General Discussion chevy base mgtd

This topic contains 2 replies, has 3 voices, and was last updated by  royal 9 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #304507

    urhonor
    Participant

    @urhonor

    Having a problem with engine not running smoothly, starts missing at about 2500 rpm or at the sweet cruising spot have replaced plugs,wires,rotor,cap,carburetor ,ignition module, had smoke test for vaccum leak, checked manual fuel pump output seems fine, timing is set, chevette 1.6 any suggestions appreciated

     

    #304527

    pmossberg
    Keymaster

    @pmossberg

    Giving this a bump up.

    Any of you Chevy guys have any advice for “urhonor”?

    Paul Mossberg
    1982 Classic Roadsters Ltd. Duchess (VW)
    2005 Intermeccanica Roadster

    If you own a TDr and are not in the Registry, please go to http://tdreplica.com/forums/topic/mg-td-replica-registry/ and register (you need to copy and paste the link)

    #304529

    royal
    Participant

    @royal

    Well, it appears that you have eliminated all the usual suspects.  So let me go to the less than obvious.  I once had a Ranger pickup that did the same thing and it was due to a clogged exhaust.  In my case, a clogged catalytic converter which i doubt you have….just a thought.

    Also, the same symptoms of a bad choke?

    • This reply was modified 9 months, 2 weeks ago by  royal.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Skip to toolbar