Skip to toolbar

Speedometer problem

Home Forums MGTD Kit Cars VW Based Kits Speedometer problem

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #232993
    Dennis Brock
    Participant

    @dbrock

    Speedometer on my MIGI just died.  Having no luck finding a replacement.  My speedo had a black face and MG Magic has only white in a complete kit for $500 plus dollars!  I took it to a speedo shop and they said that they couldn’t repair it.  I’m looking for help, either in the form of a used one that still works, or info.  The guage is about 3 3/8 (don’t know where you measure, the body or the bezel) and is VDO.

    #241401
    edward ericson
    Participant

    @edsnova

    Might try egauges.com

    VDO Vision black 3 3/8-inch available here:

    http://www.egauges.com/vdo_mult.asp?Type=Speedometer&Ser ies=Vision&Units=E

    85 or 120 mph units are like $115 + shipping

    #241402
    Dennis Brock
    Participant

    @dbrock

    I have seen these gauges, but the electronics type gauges apparently need a sending unit.  Mine is the old cable from the front wheel type which I would prefer to keep.  Thanks for the lead, that might be how I need to go.

    #241403
    Dale Schumacher
    Participant

    @schu

    d,

    I may have one – I will check.

    Dale

    #241404
    Dennis Brock
    Participant

    @dbrock

    Thanks, if you would like to contact me, I can give you my email or phone number.

    #241405
    Dale Schumacher
    Participant

    @schu

    d,

    I think I have what you need – it’s part of a set I took off my car when I

    restored it and believe it worked fine when I took it off.

    It’s about 3 1/4 at the top – maybe a bit more and is in MPH around the

    edge w/ KPH on the inside. It is black faced VDO w/ 36,000 plus on the

    clock. I aleady took the oil temp out of the set so I guess I could let it go

    by itself, but would rather sell the rest as well.

    Looks in good shape mostly but the black edge will need to be sanded

    and repainted. Just noticed one bit of bad – right by the trip knob is a

    small crack about 1/4 to 1/2 inch long right on the edge – not real big,

    but there – you might be able to take the glass off of yours and put on

    this one.

    Let me know – I can send a picture to your email when I get back from

    Carlisle on Monday or Tuesday and you can make a offer if wanted.

    Dale

    #241406
    Dennis Brock
    Participant

    @dbrock

    Sounds good, I  don’t need the other gauges, but if I had spares for the speedo I wouldnt need one now.  I would be happy to take them all, but you are the seller, and I would rather you set the price.

    #241407
    Dale Schumacher
    Participant

    @schu

    dbrock,

    Send me your email and I will send you a couple of pictures.

    Dale

    #241408
    Dennis Brock
    Participant

    @dbrock

    I did send it, let me know if their was a problem.  I have not previously used the “private communications”.

    #241409
    Scott A Chynoweth
    Participant

    @1oldbuzz

    dbrock

    I also have a speedo;black face with chome trim.

    send me an email at

    scottandlynne@sbcglobal.net

    if interested and more details

    #241410
    chuck schmit
    Participant

    @chuckles

    Hi Dbrock

    I can repair your speedofor you for free! The shops don’t like to spend the time with the crimped on front bezel. That was one of the first repairs I had to do on my MiGi! It took about an hour and was fun for me!

    Chuck

    650 24th av

    Santa Cruz, Ca 95062

     

    #241411
    Dennis Brock
    Participant

    @dbrock

    That sounds wonderful.  I really would like to keep the original speedo.  I would be happy to pay though!

    #241412
    Dennis Brock
    Participant

    @dbrock

    It was mailed yesterday!

    #241413
    chuck schmit
    Participant

    @chuckles

    I fixed it for you. The only tough part is uncrimping the bezel which holds the glass on the front of the speedo. Inside, you had the same problem as I did with mine. The little drive gear gets stuck due to lack of lubrication. The worm gear on the spinning main shaft then simply screws itself out pulling itself out of the spinning magnet. Then every thing stops working. I just take the whole thing apart CAREFULLY and clean and lube things up with light weight oil (electric motor oil works fine)and reassemble. You have to press the magnet back onto the main shaft using a vice or small hammer. A little loc-tite helps keep it on.

    This has been the exact same problem on 2 out of 2 vdo speedos that I’ve touched in my whole 70 years, so You other guys might want to lubricate and prevent the problem ahead of time. There used to be a speedo lube that came in a small squeez bottle and screwed onto the cable input portrusion on the speedo making it possible to get some oil into the bushing and gear without removal and disassembly. J C Whitney may still have this???

    How do you want me to ship this back to you?

    Chuck

    #241414
    Paul Mossberg
    Keymaster

    @pmossberg

    Proof once again what a great place this site is.

    Nice work Chuck!

    Paul Mossberg
    Former Owner of a 1981 Classic Roadsters Ltd. Duchess (VW)
    2005 Intermeccanica Roadster

    If you own a TDr and are not in the Registry, please go to https://tdreplica.com/forums/topic/mg-td-replica-registry/ and register (you need to copy and paste the link)

    #241415
    Dennis Brock
    Participant

    @dbrock

    You can ship it however is easiest for you. I definately want to reimburse you for the postage.  Let me know what it is.  I also would like to buy you and whoever you would like to take, a dinner.  I’ll get a gift card for any national chain.  Applebys, Olive Garden, Ruby Tuesdays, Outback etc.  Give me a suggestion as to your favorite.  Again, many thanks!

    #241416
    chuck schmit
    Participant

    @chuckles

    Hi

    OK, if you insist. There is an Applebees close by that would be fine.

    I’ll drop this in the mail today (usps) and thanks

    Chuck

    #241417
    edward ericson
    Participant

    @edsnova

    Three cheers for Chuckles!

    You, sir, are a good egg.

    #241418
    Dennis Brock
    Participant

    @dbrock

    Received the repaired speedo from Chuckles.  Excellant job of repair.  When installing it I found that the speedo cable was broken.  I don’t know if the cable helped cause the speedo problem, or if the speedo seized causing the cable problem.  MG Magic is sending a new one.  I guess that everyone might consider lubing both the speedo and the cable.  Bye the way Chuck, your certs are on the way.  Again, many thanks

    #241419
    chuck schmit
    Participant

    @chuckles

    Hi Dennis

    The speedo was locked up which will twist off the cable. You can buy the cable inner part at most auto supply stores and cut to your required length. It comes with a little tool to crimp the end on and works great and saves you the work and expense of changing the whole thing (assuming that it’s still in good shape).

    Thanks

    chuck

    #241420
    chuck schmit
    Participant

    @chuckles

    Hi Dennis

    Got the gift certificates.

    Thanks

     PS: How does the speedo work

    Chuck

    #241421
    Dennis Brock
    Participant

    @dbrock

    got the cable and put it on yesterday.  All is well, thanks again.  I was getting tired of using the tach as a speedo!

Viewing 22 posts - 1 through 22 (of 22 total)
  • You must be logged in to reply to this topic.